Fix ESLINT lib


  • administrators

    dcai@ICF2009542 next-feathers % npm list -g --depth 0
    /Users/dcai/.nvm/versions/node/v10.19.0/lib
    ├── @feathersjs/cli@4.3.0
    ├── create-next-app@9.3.5
    ├── csvtojson@2.0.10
    ├── UNMET PEER DEPENDENCY eslint@7.0.0
    ├── eslint-plugin-react@7.19.0
    ├── knex@0.20.10
    ├── mongoose@5.9.6
    ├── npm@6.13.4
    ├── npm-check-updates@4.0.4
    └── serverless@1.67.3

    npm ERR! peer dep missing: eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0, required by eslint-plugin-react@7.19.0
    dcai@ICF2009542 next-feathers % npm install -g eslint
    /Users/dcai/.nvm/versions/node/v10.19.0/bin/eslint -> /Users/dcai/.nvm/versions/node/v10.19.0/lib/node_modules/eslint/bin/eslint.js

    • eslint@7.3.1
      added 2 packages from 4 contributors, removed 31 packages, updated 17 packages and moved 2 packages in 4.464s
      dcai@ICF2009542 next-feathers % npm list -g --depth 0
      /Users/dcai/.nvm/versions/node/v10.19.0/lib
      ├── @feathersjs/cli@4.3.0
      ├── create-next-app@9.3.5
      ├── csvtojson@2.0.10
      ├── UNMET PEER DEPENDENCY eslint@7.3.1
      ├── eslint-plugin-react@7.19.0
      ├── knex@0.20.10
      ├── mongoose@5.9.6
      ├── npm@6.13.4
      ├── npm-check-updates@4.0.4
      └── serverless@1.67.3

    npm ERR! peer dep missing: eslint@^3.0.0 || ^4.0.0 || ^5.0.0 || ^6.0.0, required by eslint-plugin-react@7.19.0
    dcai@ICF2009542 next-feathers % npm install -g eslint-plugin-react
    npm WARN eslint-plugin-react@7.20.3 requires a peer of eslint@^3 || ^4 || ^5 || ^6 || ^7 but none is installed. You must install peer dependencies yourself.

    • eslint-plugin-react@7.20.3
      added 1 package from 1 contributor, removed 7 packages and updated 7 packages in 1.942s
      dcai@ICF2009542 next-feathers % npm list -g --depth 0
      /Users/dcai/.nvm/versions/node/v10.19.0/lib
      ├── @feathersjs/cli@4.3.0
      ├── create-next-app@9.3.5
      ├── csvtojson@2.0.10
      ├── eslint@7.3.1
      ├── eslint-plugin-react@7.20.3
      ├── knex@0.20.10
      ├── mongoose@5.9.6
      ├── npm@6.13.4
      ├── npm-check-updates@4.0.4
      └── serverless@1.67.3